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SDFlash Algo Disclaimer
Please check the Spectrum Digital website for future updates.

The SDFlash Algorithm files in this download include the following Flash Application
Program Interface (Flash API) libraries:

o F28044 V1.00: Flash28044_API_V100.lib

Texas Instruments Inc. (TI) reserves the right to update or change any material included with
this release. This includes:

aThe API functional behavior based on continued TMS320F2804x testing.
olmprovements in algorithm performance and functionality.
It is the user’s responsibility to check for future updates to the SDFlash Algo Files based on
any updates to the F2804x Flash APIs and to use the latest version available for their F2804x
silicon.
Updates to the API will be posted on the Texas Instruments Inc website (www.ti.com) and
can also be obtained by contacting Texas Instruments’ support. Updates to the SDFlash

algorithm files will also be posted on the Spectrum Digital website
(www.spectrumdigital.com.)
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1. Revision History

This is the revision history for the F2804x algorithm builds for SDFlash. Note that the SDFlash algorithm build
version is separate from the SDFlash front-end utility version.

Version 1.0

Q

Initial release

2. Release Notes

a

a

The flash APIs used in this release are available on the Tl website. Please check the T| website for future
updates to the APIL.

Some traditional programming utilities have separate operations for “Clear” and “Erase”. These two
operations have been combined into one operation referred to only as “Erase”.

Note: The CSM will be permanently locked if the CSM password locations are loaded with all 0x0000
and the device is secured. During the combined “Erase” function, a sector clear is immediately
followed by an erase operation without resetting the device. This will help avoid permanently
locking the CSM. Do not program the CSM passwords with all 0x0000.

SDFlash does not support the XDS560 scan controller.
You should not run SDFlash and Code Composer at the same time. This results in two different

applications trying to control the DSP. During programming, SDFlash will have complete control of the
device. No user application code can be running in parallel.

3. Known Limitations

O SDFlash only programs sections linked to page 0 (i.e. program) memory. It is important to make sure that
sections such as .switch, and .const/.econst section are linked to page 0 and not page 1 for SDFlash to
program it.

O When specifying User Options for SDFlash functions do not use a leading Ox in front of the number. Enter
only the hex value with no leading Ox. For example: correct: 03FF incorrect: Ox03FF

Texas Instruments Inc. 4
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4. API Revision vs. Silicon Revision

The silicon revision can be determined by the lot trace code marked on the top of the package. Refer to the device
specific errata for information on how to determine your device’s silicon revision from the device symbolization. In
addition, the silicon revision can be read from the REVID register located at address 0x883 as shown in the tables
below.

SDFlash Algo release information for F28044:

Second Letter In REVID Obsolete Recommended
Prefix of Trace Lot | (Addr 0x883) SDFlash JTAG Algorithms SDFlash Version
Code
Blank 0x0000 none V1.0 or Later
Note:

For future silicon revisions, Tl anticipates that no functional changes will be required to these
APIs (and hence no changes should be required to SDFlash algorithms).

Should API changes occur that affect the programming of the flash, it is the user’s
responsibility to update any application that uses the API (programmers, embedded software,
etc) to insure proper long-term operation of the flash. Tl will test these APIs on future silicon
revisions as soon as possible when such devices become available. Updates that only add
features are not required.

Q Texas Texas Instruments Inc. 5
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5. SDFlash Overview

SDFlash is a generic front-end application owned by Spectrum Digital Inc (www.spectrumdigital.com). This
application provides a generic interface to the JTAG communications channel that can be used to support flash
programming.

In order to erase or program flash, SDFlash downloads a flash algorithm file onto the DSP. This algorithm file is an
executable (.out) file for the DSP being programmed and is executed on the DSP target. For the F2804x, the
SDFlash algorithm file consists of an SDFlash wrapper and the F2804x Flash API library. The SDFlash wrapper
has well defined standard functions and variables that are accessed by SDFlash over the JTAG channel. These
functions in turn make calls to the Flash API Library to perform operations on the flash array. Note: because the
SDFlash interface is separate from the algorithm file, the version of the SDFlash interface will differ from the version
of the algorithm file.

SDFlash [\
Wrapper *
A s
v . SARAM DSP
A )
Flash API kY Buffer PC
«d “‘ Flash Data File
Toeal N TN (-out to be
e programmed)
SDFlash Algo
" | JTAG [ SORE
JTAG
v Front-End \
CPU SDFlash
Algorithum File
OTP and
FLASH
ARRAY
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For SDFlash to erase or program the flash on a device, it must have

Flash Data the following information:
File O Location of the SDflash algorithm file

O Location of the flash data file — that is the data (.out file)
to program into the device.

Algo File ! A
SDFlash Project a Any_ user defme_d options.
(.sdp) _ Q Which JTAG driver to use
Options Q Information about the JTAG scan chain
Communications All of this information is stored in an SDFlash project file (.sdp) that
Driver can be edited though the SDFlash GUI interface. A sample
SDFlash project for each F2804x device has been provided in this
download.

Section 6 of this document will guide you through the SDFlash setup and show you how to use the provided sample
SDFlash projects to create your own project and flash the F2804x device.

For example F2804x code that executes from the flash, refer to the following available from the TI website:
a Device appropriate C/C++ Header Files and Peripheral Examples

O Running an Application from Internal Memory on the TMS320F28xx DSP (SPRA958)

6. Quick Start Guide
The following is a step-by-step guide for using the SDFlash utility for 28xx.
This quick start guide will refer to the following default directory locations:

<CCS> default Code Composer Studio install directory: "c:\ti"
<SDFlash> default SDFlash directory <CCS>\specdig\SDFlash

These directories may be different for your particular installation.
6.1. Make sure the target and emulator are setup properly:

» If you are using an XDS510/XDS510pp+/SP1515 emulation controller, use the SDConfig utility. The
SDConfig is part of the default emulation installation and will be installed in your
<CCS>\specdig\sdconfig directory

Q Texas Texas Instruments Inc. 7
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6.2. Install the SDFlash flash support utility.
SDFlash will typically be installed in your <CCS>\specdig\SDFlash directory.
SDFlash is a generic utility supplied by Spectrum Digital Inc. to interface to user written algorithms. In
this case, Texas Instruments Inc has supplied the algorithm file. Users should check the SD website for
updates to this utility.

6.3. Download the latest F2804x SDFlash algorithm files.
Upgrades will be available for download from the Spectrum Digital website in the
Support Utilities->SdFlashAlgo’s section.
CAUTION
The current version of the algos is considered beta material for initial sampling.
Please check Spectrum Digital’s website for future updates.

6.4. Unzip the F2804x SDflash algorithm files into the myprojects subdirectory of SDFlash. For a

typical install this will be the <CCS>\specdig\SDFlash\myprojects directory.
=l | ) specdig
This will automatically create a directory indicating the processor and ) sdcanfig
version of the utilities. 3 O sdflash
Note: If you had installed an earlier release of SDFlash on your * 1 bin .
system you may have additional sub-directories to those shown, such . m‘*’d””_ers
as an algo directory. With the release of SDFlash V1.3 the algo = ) myprojects
directory was replaced with the myprojects directory. Presence of this 1) biF2E1x _v4 0
directory will not effect the operation of SDFlash. =l | kf2804%_v1_0
) doc
6.5. Run SDFlash. + |5 Fza0d4d
_ ) ) + | ) Fea04s
Load the supplied SDFlash sample project. SDFlash uses project
files to store information required to erase a device and program an .out file into a device. Sample
projects have been included in tif2804x_v1_0.zip for use as project templates.
Using File->Open Project in SDFlash, browse to and load the appropriate sample SDFlash project.
These sample projects program a flash image that is an address = data pattern. The CSM password is
not programmed. For a typical installation, these files will be found in the following location:
F28044: <SDFlash>\myprojects\tif2804x_V1_0\f28044\SampleF28044.sdp
Texas Instruments Inc. 8
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6.6.

Modify the SDFlash project (if required) to locate the various elements such as device driver,
algorithm file and flash data file.

If you installed Code Composer Studio (CCS) and SDFlash in the <CCS base> and <SDFlash base>
directories shown below, then usually only the Flash Data File on the Program Tab, and possibly the
Emulator Address/ID on the Target Tab needs to be changed.

By default all flash projects are setup relative to the default Code Composer Studio 3.1 base directory "
CCsStudio_v3.1". For example:

The location of the SDFlash directories may be different for your particular installation.
For example, the <CCS base> directory for some older Code Composer Studio
installations will be c:\ti\.

In this case, the SDFlash project will need to be updated to reflect the directory
structure of your install.

To change any of the directory paths or project settings from their default values, open
the project settings dialog box: Project->Settings

<CCS> default Code Composer install directory: "CCStudio_v3.1"

<SDFlash> default is <CCS>\specdig\SDFlash

SDFlash binary default is <CCS>\specdig\SDFlash

Flash projects default is <CCS>\specdig\SDFlash\myprojects\<projectname>
NOTE

To change any of the directory paths or project settings from their default values, open the project settings
dialog box: Project->Settings

The fields that require directory paths in the Project->Settings window are summarized below:

Target Tab: Erase Tab: Programming Tab: Verify Tab:
-Driver -Algorithm File -Algorithm File -Algorithm File
-Board File -Flash Data File

Target Tab:

O Driver: This is the Code Composer Studio'" emulation driver (*.dvr) file that is used to communicate
with the target. The driver files can be found in the <CCS>\drivers\ directory.

default for other 510PP+/SPI515 etc:  <CCS>\drivers\sdgo28x.dvr

O Emulator Address/ID: default is 378 for the 510pp, it is 510 for the USB driver. This address must
match the setting in your SDConfig setup.

O Board file: File that provides SDFlash information on how many devices are on the JTAG scan
chain. For a single 28x device on the scan chain, the default board file can be used. For systems
with more devices on the scan chain, use the board file generated by Code Composer Studio to
access your device. This file is found in the <CCS>\cc\bin\BrdDat directory.

The default board file is <SDFlash>\myprojects\tif2804x_V1_0\ccBrd028x.dat

O Processor name: default is cpu_0

Q Texas Texas Instruments Inc. 9
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Erase Tab:
a Algorithm File:
F28044: <SDFlash>\myprojects\tif2804x_V1 0\f28044\flash28\Debug\SDFlash28044_erase.out

Q Timeout: leave as 3000

O User Options 1: Erase sector mask default is 000F.
See section 9 for more information.

Q For all other boxes the default is blank.

Program Tab:
a Algorithm File:

F28044: <SDFlash>\myprojects\tif2804x_V1 0\f28044\flash28\Debug\SDFlash28044_program.out

Q Flash Data File: This is the .out file that you want to program into the flash. The sample image
provided with the algorithm is a simple data = address pattern. The code security module
password locations are not programmed by the sample image. That is, the CSM password
locations are left erased (all OXFFFF’s) so that the CSM can easily be unlocked.

If you have your own .out file ready to be programmed you can specify that file as the data file.
The sample image Flash Data File is located at:

F28044: <SDFlash>\myprojects\tif2804x_V1 0\f28044\image\Debug\image28044.out
Q Timeout: leave as 3000

Q For all other boxes the default is blank.

Verify Tab:
Q Algorithm File:

F28044: <SDFlash>\myprojects\tif2804x_V1_0\f28044\flash28\Debug\SDFlash28044_verify.out
O Timeout: leave as 3000
O User Options 1: Flash wait states: default is OFOF
O User Options 2: OTP wait states: default is 001F

Q For all other boxes the default is blank.

Q Texas Texas Instruments Inc. 10
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6.7. Save the SDFlash project file: File->Save Project As. Once you have made the required changes
select ok and save the project using the name of your choice: File->Save Project As.

If you changed the Emulator Address/ID setting on the Target Tab, you should get a message that the
current driver was unloaded and a new driver has been loaded. This operation is required to
synchronize the SDFlash project settings with SDConfig. If you did not change the Emulator
Address/ID, then you will not get this message.

You have now created an SDFlash project that can be used anytime you want to erase or program the
device using these settings. Should you want to program a different .out file into the F2804x flash, use
this project as a template and change the Flash Data File on the Program Tab.

6.8. Configure the algorithm for the required PLL multiplier and CPU frequency.

For custom CPU frequency and PLL multiplier, you must follow the instructions in section
7 to properly configure the algorithms before continuing. As supplied, the algorithm is
configured for:
PLLCR = 0x000A (PLL x10/2 mode), and CPU frequency = 100MHz

CAUTION
The erase and program operations MUST be configured for the CPU clock rate
(SYSCLKOUT) at which they will run.  This configuration is VITAL for proper
operation of the algorithm.
As supplied, the algorithm is configured for:
PLLCR = 0x000A (PLL x10/2 mode), and CPU frequency = 100MHz
For custom CPU frequency and PLL multiplier, you must follow the instructions in
section 7 to properly configure the algorithms before continuing.

6.9. Optional: View which sections are going to be programmed (i.e. loaded) using the
View->Coff/Hex file stats SDFlash function.

Q Make sure that no RAM locations are marked as load sections.

O Constant sections (i.e. .const/.econst) must be linked to page 0 (i.e. program memory) for
SDFlash to program them.

Q Itis suggested to not program the CSM password locations (0x3F7FF8-0x3F7FFF) during
development since flash contents will be changed often.

Q If programming the OTP, note that it can only be programmed once. It cannot be erased.

6.10. Reset the device: Device->Reset. You will get a pass/fail message in the output window.

6.11. Erase/Program/Verify your device: Device->-Flash. Check or un-check the operation(s) you want to
perform then select start. Each checked operation is executed from left to right, with continue on
success and abort on fail. Refer to Section 11 for tips should a failure occur.

Texas Instruments Inc. 11
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CAUTION

Do not press the SDFlash STOP button during the erase operation.
Pressing STOP will halt the CPU before the Erase algorithm completes. This can leave
the Flash in a depleted state or result in unknown Code Security Module passwords
and lock the device permanently.
Other conditions that can cause the CPU to halt prior to the completion of the Erase
algorithm (e.g., power loss, device reset, PC crash, etc.) can result to the same problem
described above.

Pressing STOP when executing the frequency toggle test described in section 9.3 is ok.

6.12. Optional: Repeat erase/programming for each device to be programmed. If additional devices are
to be programmed, the target can be powered down and a new target connected without closing the
SDFlash utility. Once the new target is connected, reset the part (Device->Reset) and erase, program,
verify (Device->Flash) the device as described in 6.10 and 6.11.

6.13. Optional: View the flash contents using Code Composer Studio™ (CCS). You can view the
programmed flash using CCS, and compare with your source code.

Make sure that the SDFlash utility is closed before starting CCS.

Start CCS and open a memory window to view the flash contents (or use the disassembly window). In
addition you can load the CCS project and load the symbols from the .out file.

Q Texas Texas Instruments Inc. 12
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7. PLL and CPU Clock Rate Configuration

CAUTION

The F2804x Flash APl used by SDFlash contains several delay parameters that

are implemented as software delays. Timing of these delays is VITAL to proper
operation. To ensure the proper delays, the flash algorithms must be run at the
correct speed.

As shipped, the algorithms are configured for the following:

20 MHz input clock

x10 PLLCR (0x000A)

% CLKINDIV enabled

This results in a 100 MHz CPU clock (SYSCLKOUT)

If your hardware requires any of the following:

a different CPU rate (SYSCLKOUT) then 100MHz

or requires a different PLLCR setting then 0x000A

or requires the PLL to be disabled

or requires that CLKINDIV is set (1/2 disabled in this case PLLCR must
be set to 0x0000)

then you must modify and re-compile the flash programming algorithms for
your system'’s specific requirements as described below:

The following steps describe how to compile a new SDFlash algorithm file for a custom frequency and
PLL Control Register (PLLCR) setting.

Using Code Composer Studio (CCS), load the projects for your device. There is one project per

operation and all must be re-compiled for the new PLL configuration. These are the CCS projects
used to build the SDFlash algorithm files. The projects are:

F28044: Install Dir: <SDFlash>\myprojects\tif2804x_V1_0\f28044\flash28\

SDFlash28044 Erase.pijt, SDFlash28044_Program.pijt,
SDFlash28044 Verify.pjt SDFlash28044 DepRecover.pjt
Texas Instruments Inc. 13
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7.1.

7.2.

Specify the required PLLCR (PLL Control Register) value.

In CCS, open and modify SDFlash2804x_Wrapper.h to specify the PLLCR (PLL Control Register)
value. Uncomment the line corresponding to the required PLL Control Register (PLLCR) setting. This is
done by removing the leading // in front of the correct line. Only one line should be uncommented.

For example: To have the algorithms initialize the PLLCR register to 0x0009 uncomment the second
line and comment out the remaining lines as shown:

/] #define PLLCR_VALUE O0x000A /1 SYSCLKOUT
#define PLLCR_VALUE 0x0009 /1 SYSCLKOUT
/1 #define PLLCR_VALUE 0x0008 /1 SYSCLKOUT
etc .....

( OSCLK* 10) / 2
( OSCLK*9) / 2
( OSCLK*8) / 2

Specify the clock rate of the CPU (SYSCLKOUT) in nanoseconds. In CCS, open and modify the
API configuration file Flash2804x_API_Config.h to specify the clock rate of the CPU (SYSCLKOUT) in
nanoseconds. This is done by removing the leading // in front of the correct line. Only one line should
be uncommented. The file lists a number of commonly occurring clock rates. If your CPU clock rate is
not listed, then provide your own definition using the examples as a guideline.

For example: Suppose the final CPU clock rate will be 80 Mhz. This corresponds to a 12.5 nS cycle
time. There is no line present for this clock speed, so you should insert your own entry and comment
out all other entries:

/I #define CPU RATE 10.000L /1 for a 100MHz CPU cl ock speed (SYSCLKOUT)
#defi ne CPU_ RATE  12.5000L /1 for a 80MHz CPU cl ock speed (SYSCLKQOUT)

/] #define CPU RATE 13.330L [l for a 75MHz CPU cl ock speed (SYSCLKOUT)
/] #define CPU RATE 20.000L /1 for a 50MHz CPU cl ock speed (SYSCLKOUT)

CAUTION
For flash integrity at operating frequencies, the device should always be programmed
at the fastest possible CPU frequency. For example, if the CLKIN frequency is 20 MHz
program the device at 100 MHz rather then 10 MHz or 20 MHz.

The flash utilities are not designed to function properly below 10 MHz.

Q Texas Texas Instruments Inc. 14
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7.3.

7.4.

7.5.

7.6.

If your system requires any other custom setup such as modifying the CLKINDIV bit then:

Open the SDFlash2804x_Main.c file. The code that is executed on startup to setup the PLL is at the
beginning of the main() function within this file. Modify this function as required for your clock
requirements.

Rebuild each of the algorithms in CCS by selecting Project->Rebuild all.

CAUTION

It is important to rebuild all of the algorithm files: erase, program, verify and depletion
recovery.

Exit Code Composer Studio

Run the CPU frequency and PLL multiplier configuration toggle test described in section 9.3
from SDFlash to verify the configuration.

When run, this test will toggle a selected GP I/O pin at a known frequency. This will allow you to
confirm that the algorithms are properly configured for the CPU frequency and PLL multiplier you
specified.

CAUTION

It is strongly recommended that you test the CPU frequency and PLL configuration
using the configuration toggle test described in section 9.3 before erasing or
programming any parts.

If this test fails, DO NOT PROCEED to erase or program the flash until the problem is
corrected, or flash damage can occur.

The SDFlash algorithm file should now be configured for your hardware’s frequency requirements.

Q Texas Texas Instruments Inc.
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8. Code Security Module (CSM) Password Considerations

The F2804x SDFlash algos must unlock the Code Security Module (CSM) before an erase, program, or verify
operation. As supplied, the password locations are assumed to be all erased (all OXFFFFs). During the code
development phase, it is suggested that the CSM passwords be left erased (OxFFFFs) for ease of use. If you
program new passwords into the CSM password locations (0x3F7FF8-0x3F7FFF) and then later need to re-
program the part, you will need to configure the flash algorithms so that the CSM can be unlocked. Refer to
TMS320x2804x, System Control and Interrupts Peripheral Reference Guide, for details on the proper operation of

the CSM.

The algorithm uses the CSM keys provided in the appropriate CSM key assembly file:
(SDFlash28x_Erase_CsmKeys.asm, SDFlash28x_Program_CsmKeys.asm, or SDFlash28x_Verify CsmKeys.asm)
to unlock the CSM. Follow these steps to build an SDFlash algorithm file with a new set of CSM passwords.

8.1.

8.2.

8.3.

8.4.

8.5.

Using Code Composer Studio (CCS), load the projects for your device. There is one project per
operation and all must be re-compiled for the new PLL configuration. These are the CCS
projects used to build the SDFlash algorithm files. The projects are:

F28044: Install Dir: <SDFlash>\myprojects\tif2804x_V1_0\f28044\flash28\
SDFlash28044 Erase.pjt, SDFlash28044 Program.pijt,
SDFlash28044 Verify.pjt SDFlash28044 DepRecover.pjt

In CCS, open the appropriate CSM key file: SDFlash28x_Erase_CsmKeys.asm,
SDFlash28x_Program_CsmKeys.asm, or SDFlash28x_Verify CsmKeys.asm. These files contain
the definition of the CSM passwords used by the algorithm to unlock the CSM during the erase,
program and verify operations.

Note: The passwords in this file will not be programmed into the CSM password locations. The
algorithm uses these passwords only to unlock the CSM prior to an erase, program or verify operation.

Modify the passwords in the appropriate CSM key file to match those already programmed into
the CSM password locations.

Rebuild the algorithms in CCS by selecting Project->Rebuild All

Exit Code Composer Studio

Note: Each step in the process Erase, Program, and Verify separately unlocks the CSM. If you are changing
the passwords during the Program operation, you will need to supply the new passwords for the verify
operation by following the steps above.

Q Texas Texas Instruments Inc. 16
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9. SDFlash User Options

The SDFlash utility provides user options for each operation: Erase, Program and Verify. The function implemented
by each of the user options is dependent on the algorithm being interfaced to.

The following table shows an overview of which user options are used by the F2804x SDflash algorithm V1_0.

Erase Program Verify
User Option 1 | Sector Mask Not used Flash bank wait states
User Option 2 | Not used* Not used OTP wait states
User Option 3 | Run frequency toggle test | Run frequency toggle test | Run frequency toggle test
User Option 4 | Not used Not used Not used

* Note on 281x devices this was the frequency toggle test. This has been moved to the user option 3. The
frequency toggle test is available under all operations since each operation algorithm file is a separate compile.

The following sections describe in detail how to use each option.

CAUTION

When entering the User Options into the SDFlash interface, do not use a leading 0x.
Enter only the hex digits as shown in the examples provided.

9.1. Specify Which Sectors to Erase: Erase

User Option 1 PSD_EMU_CONTROLLER_INFO ? |X]

For the erase operation, User Option 1 allows you Target Erase ] Pragramming | Werfy |
to select which sectors will be erased. This _ _
information is provided in the form of a mask value Algarithm File:
where a set bit indicates that the sector will be |8044_v1_DM28044\flash28AD ebughSDFlash28044_Erase.out J
erased.

F2844
Bit 0 = Erase Sector A )
Bit 1 = Erase Sector B Timeout: {3000 STI |
Bit 2 = Erase Sector C
Bit 3 = Erase Sector D =TI |
Bit 4-15 = ignored Uszer Ophions 1 ooF FMST: |
To modify the sector mask value: User Options 2: PMST dddress: |
9.1.1. Open the project settings: Recr RS &

Project -> Settings User Optiohs 4:
9.1.2. Click on the Erase tab

k. | Cancel Help
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9.1.3. Enter a mask value for User Option 1 that corresponds to the sectors you want erased. Enter the hex

number digits only.

Do not enter a leading 0x. For the example shown: Erase User Option 1 = 000F would erase all sectors on

a F28044 device.

9.1.4. Select OK and save the project: File->Save Project

CAUTION

The OTP block cannot be erased.

The One Time Programmable Block (OTP) can only be programmed once.

CAUTION

recovery algo.

Do not press the SDFlash STOP button during the erase operation.
Pressing STOP will halt the CPU before the Erase algorithm completes. This can leave the Flash in a

depleted state or result in unknown Code Security Module passwords and lock the device
permanently. If you feel your device is in a depleted state (cannot be erased) then try the depletion

Other conditions that can cause the CPU to halt prior to the completion of the Erase algorithm (e.g.,
power loss, device reset, PC crash, etc.) can result to the same problem described above.

Pressing STOP when executing the frequency toggle test described in section 9.3 is ok.

F28044 Sector Mask Value: F28044 Sector Addresses:

Bit 0 = Erase Sector A

Bit 1 = Erase Sector B ADDRESS RANGE PROGRAM AND DATA SPACE
Bit 2 = Erase Sector C Th3E 5000 r
Bit 3 = Erase Sector D 0x3E BFFF Sector D (16K x 16)
Bit 4-15 = ignored S o i
0x3E FFFF =eciori- {16 x 15)
0x3F 000D . .
03F 3FFF Sector B (16K x 16)
0x3F 4000 . .
03F TFTF Sector A (16K x 16)
Ox3F TFE0 Program to 0x0000 when using the
Ox3F 7TFFS Code Security Module
Ox3F 7FF& Boolto-Flash Entry Point
Ox3F 7TFFT {program branch instruction here)
Ox3F 7FF5 Security Pazsword (125-Bit)
0x3F 7FFF (D not program fo all zercs)
F28044 Erase User Option 1 Examples: 0001 Erase only sector A

0003 Erase only sector A and sector B
OO0OF Erase all sectors on an F28044 device

Q Texas Texas Instruments Inc.
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9.2. Configure Flash and OTP wait states: Verify User Option 1 and Verify User Option 2

Verify User Option 1 and User Option 2 allows you to specify Verify

wait states used for the Flash and OTP memory during the User Option 1 | Flash bank wait states

verify operation. This option can be used to increase the speed | US€r option 2 | OTP wait states
of the verify operation or allow you to match the wait states used | US€r option 3 | Toggle test (section 9.3)

in your application if desired. User Option 4 | Not used

CAUTION:

Frequency limits for both the Flash and OTP blocks are documented in the device
Data Manual (SPRS174). Refer to the Data Manual for the minimum access time of
the Flash and OTP memory. Using a wait state value that is too low will cause the
verify operation to fail.

Verify User Option 1 specifies the Flash waitstate register (FBANKWAIT) contents:

12 1 8 7 4 2 [i]
Reserved PAGEWAIT Reserved RAMDWAIT I
R-0 RW-1 R-0 RMW-1

FBANKWAIT Register | ©

The sample SDFlash project uses the default value of OFOF. This value is also used if the option is left blank.

Verify User Option 2 specifies the OTP waitstate register (FOTPWAIT) contents:

15 | | s 4 | o
FOTPWAIT Register | Fesarved I OTEWAIT I
R-0 RW-1
PSD_EMU_CONTROLLER_INFO ! |
The sample SDFlash project uses the default value Target] Eraze ] Pragramming ey ]
of 001F. This value is also used if the option is left
blank. Algarithm File:

. |EEId:-:_'-.-"I_D"-.fEEDAM'xfIaShEE'xDel:uug'\SDFIashEEDM_"»-"erif_l,l.Dut J
To set the wait state values:

FBANKWAIT register

i i - imequt: [F000
9.2.1. Open the project settings: Project -> Timeout. B
Settings
i i i - |OFOF STO:
9.2.2. Click on the Verify tab User Options 1: |
User Options 2 (001F 5T1: |

9.2.3. For User Options 1 enter the value for the

; Ilzer Options 3: FMST: |

Uzer Opticns 4: PHST Address:

9.2.4. For User Options 2 enter the value for the
FOTPWAIT register

9.2.5. Select OK

9.2.6. Save the project: File->Save Project oK. | Cancel Help
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9.3. CPU Frequency and PLL Multiplier Configuration Toggle Test: User Option 3

User Option 3 turns on and off the frequency configuration toggle test. This test is used to confirm that the
algorithms are properly configured for the CPU frequency and PLL multiplier. Refer to section 7 for information on
how to configure the algorithm for the frequency of your CPU.
The toggle test is available as user option 3 for erase, program and verify because the algorithm file for each of the
operations is a separate compile. At initial setup, it is recommended that the frequency configuration of at least the
erase and program operations are verified via the toggle test.
To run this test:

9.3.1. Open the project settings: Project -> Settings

9.3.2. Click on the appropriate tab: erase, program, verify

9.3.3. For “User Options 3", enter the value that corresponds to the pin you want to toggle as shown in the table.
Enter the value as hex digits only. Do not enter a 0x in front of the value.

In the example shown, 0022 in erase User PSD._ EMU_CONTROLLER_INFO : |

Options 3 indicates that the toggle test will be run _ _
on GPI034 instead of the erase operation. Target Erase | Programming | Verty |
Algarithm File:

Erase, Pin Toggled |E!Eld:-t_v'l_DKF2ED44HFIaSh28HDel:uug'\SDFIashEE!EIM_Era&e.out J
Program and (100uS cycle time)
Verify
User Option 2
blank Test not run Timeout; |2000 ST0: l—
0000 GPIO0
0001 GPIO1 5T
888; gE:gg User Dptions 1; |000F PMST:
0004 Y Llser Options 2: PrST Address:
0005 GPIOS... User Options % |22
Ulzer Options 4:
000A GPIO10
0022 GPI0O34 (] % | Cancel Help
0023-FFFF Test not run

CAUTION

Choose an appropriate pin for your system. Check your board design and board
connections to be certain that the pin you have selected for toggling is not being
driven by a source other than the DSP, or voltage contention can occur. Also, be
certain that whatever the toggling pin is connected to in your system will not
encounter difficulty when the pin is toggling (e.g., the device the pin is connected to
should be powered-down, held in reset, etc.). A number of different pins are selectable
above in order to avoid such problems,

9.3.4. Click Ok and save the project: File->Save Project
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9.3.5. To begin the toggle test, start a SDFlash operation using the Device->Flash menu.

Uncheck any operations you are not using. For example, if you want to check the frequency configuration
of the program algorithm, uncheck the erase option and press start.

With User Option 3 set to 0000 - 0022, the toggle test will be performed instead of the specified operation
and SDFlash will eventually timeout. The timeout period is as specified in the Timeout box, in seconds
(e.g., 3000 seconds). The user can click Stop to halt the toggle test sooner.

While the test runs, monitor the selected pin using an oscilloscope. If the algorithms are configured
correctly for your CPU rate then the pin will toggle near 10kHz (100uS +/- 10uS cycle time).

If the pin is toggling at a different rate, then the algorithms are not configured correctly. Follow the
instructions detailed in section 7,

10. Depletion Recovery Algorithm

This release of the SDFlash utilities includes a depletion recovery algorithm. This algorithm is called instead of
erase for the following projects:

SampleF28044 DepRecover.sdp

Note: These sample projects are setup for depletion recovery only and do not contain code to perform a program or
verify operation. Thus, these operations will report a failure but do not perform any operation on the device.

How does depletion occur?

If the erase operation is interrupted and not allowed to complete the device may become depleted. When this
happens, the device may then begin to fail to erase. All efforts should be taken to not stop the erase algorithm as
this can also affect the CSM passwords. If the passwords are in an unknown state then the device cannot be
recovered. If, however, the CSM passwords are known and the device can be unlocked, then the depletion
recovery algorithm can be run to try and recover the part.

The depletion recovery algo looks for sectors that are in depletion and attempts to recover them. All sectors on the
device are checked.

The current maximum timeout for the algorithm is approx 35 seconds per sector that is in depletion.

Typically only one sector would be in depletion unless erase has been called multiple times on multiple sectors
without running to completion. If a longer timeout can be tolerated, the depletion recovery can be used multiple
times.

There is no guarantee that this algorithm will be able to bring a sector out of depletion within a reasonable amount
of time. The deeper in depletion the part is, the longer it will take to recover. The Flash API erase function

has been implemented to erase the flash in such a manner that it is not put into deep depletion. However, if the
CPU is halted during an erase pulse for a long period of time the part can be put into a deep depletion that may not
be recoverable in a time period that is acceptable.

This algorithm cannot recover the part if the flash passwords are unknown. For example if power is lost during the

erase of sector A, where the CSM passwords are located, then the device may be permanently locked and the
recovery algorithm cannot operate on the flash.
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11. Troubleshooting Tips

This is a list of solutions to potential failures when using the SDFlash utility. At this point you should have the most
recent SDFlash revision installed and the proper flashing algorithms for the DSP you are using should be unzipped
in to your SDFlash\myprojects folder. Prior to using the SDFlash, the SDConfig utility must successfully run and
verify connection to your emulator and target DSP board. The SDConfig can be launched via the 'SDConfig' icon on
your Windows desktop. If you need help with the SDConfig, please refer to the SDConfig.htm file included in your
SDConfig directory.

It is recommended you begin by using one of the example projects included with the flashing algorithms associated
with the DSP you are using. Before attempting to erase or program the flash, check the Project Settings of the flash
project you are using. The project settings can be viewed by clicking the 'Project’ menu, then click 'Settings'. Verify
that each field that requires a directory path points to the location where that file is actually located. The fields that
require directory paths in the Project Settings Window are:

Target Tab: Erase Tab: Programming Tab: Verify Tab:
-Driver -Algorithm File -Algorithm File -Algorithm File
-Board File -Flash Data File

If you have installed the SDFlash and Algorithms in a directory different from the default installation directory, the
directory paths in the Project Settings will need to be changed.

11.1. DSP Reset Fails

O Check that the target DSP board is properly powered. Check that the DSP is properly clocked (check
XCLKOUT using an oscilloscope).

Q If using a stand alone JTAG emulator, make sure that it is properly powered.
O Make sure that the SDFlash Project is configured for the correct driver and port address. The SDFlash
project must be configured with the correct driver to support the Spectrum Digital JTAG Emulator or

eZdsp board you are using.

11.2. All Operations

O Refer to section 12 for a description of the API error codes that will be reported by SDFlash.
O The errors ‘File Does Not Exist' or 'Load file failed’ may appear when attempting to open the Flash
Panel. The file that the errors are referring to is the 'Flash Data File' located on the Programming tab of

the Project Settings. Verify the directory path to the COFF file you wish to load is a valid path. (i.e. that
the .out file exists in the directory entered.)

O A successful 'RESET' in SDFlash means the JTAG Emulator and Target board are properly powered
and connected. However, take a moment to verify that all cables are connected securely and that the
proper power is supplied to the emulator and target board.

O Older versions of the SDFlash algos are based on obsolete Flash APIs and should not be used.
O Run SDConfig to make sure your target and emulator are setup properly.

O Examine the project settings Project->Settings and make sure the path names to all files are correct as
described in section 6.6.
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O The flashing algorithms must be configured to multiply the DSP's input frequency appropriately and not

11.3.

exceed the DSP's maximum operational frequency. The algorithms found on the Spectrum Digital
support sites are configured to support Spectrum Digital target boards. If you are using a custom board
refer to the directions in this to properly configure the algorithms to support your target configuration.

Make sure SDFlash can unlock the Code Security Module (CSM). An SDFlash error message of "ERR:
Failed to initialize the algorithm" can indicate the CSM as the source of the problem. The algorithm
attempts to unlock the CSM before an erase, program, or verify operation. By default, the password
locations are assumed to be all erased (FFFFs). Refer to section 8 Code Security Module (CSM)
Password Considerations if you have changed your passwords from the erased value.

It is suggested that the CSM passwords be left erased (FFFFs) for initial development. Refer to the
TMS320x2804x, x2801x System Control and Interrupts Reference Guide for details on the CSM
operation.

If required, configure the SDFlash algorithms for a custom CPU frequency and PLL multiplier. As
supplied, the algorithms are configured for a CPU clock frequency (SYSCLKOUT) of 150MHz and to
set the PLLCR register to 0OX000A. If your hardware has other requirements you must configure the
algorithms as described in section 7 Confirm proper configuration of the algorithms by running the CPU
frequency and PLL multiplier configuration toggle test described in section 9.3 CPU Frequency and PLL
Multiplier Configuration Toggle Test: User Option 3

SDFlash should have full control of the device. That is, no user application should be running, no
interrupts firing, and CCS should be shut down prior to using SDFlash.

Make sure that the device has a clean VDD3VFL 3.3V voltage source. In addition VDD3VFL should
remain connected, as it is required for read operations as well as programming.

Check the part using Code Composer Studio (CCS). Using CCS, check the SARAM blocks and make
sure that you can unlock the CSM (check by attempting to view the passwords in a memory window. If
you view all 0x0000's, the CSM is still locked).

Erase Fails

Make sure a valid sector mask is specified for User Option 1 for the erase operation. At least one
sector must be specified. Do not use a Ox in front of the mask value — simply enter the hex number
without the leading Ox. For example: correct 03FF incorrect OxO3FF

If the configuration toggle test is selected via erase User Option 2, then the toggle test is executed in
place of the erase algorithm. SDFlash will timeout and report an erase error in this case. Refer to
section 9.3 CPU Frequency and PLL Multiplier Configuration Toggle Test: User Option 3

for more information.

If you programmed new security passwords, the SDFlash algorithm may no longer be able to unlock the
CSM using the default passwords. To avoid having to change the CSM passwords for different
operations, it is suggested that the CSM passwords be left erased (FFFFs) for initial development.
Refer to section 8 Code Security Module (CSM) Password Considerations if you have changed your
passwords from the default (erased) value.

Q Texas Texas Instruments Inc. 23



TMS320F2804x SDFlash Programming Utilities F2804x SDFlash Algo V1.0

11.4. Programming Fails

a

Check to make sure you are not programming a region of memory outside of the flash. To see what
sections SDFlash will program, use the View->Coff/Hex File Status utility and look for sections
labeled “load” outside of the flash memory region. It may be that the start address is within Flash or
OTP but the end address is not.

Refer to the linker section in the TMS320C28x Assembly Language Tools User’s Guide, literature
#SPRU513, for more information on preparing your code for programming. Any loaded section that
starts outside or ends outside of the flash region will cause programming to fail.

Make sure you erased the sectors being programmed prior to programming them. Make sure the
sector mask used for the erase function did not include the leading Ox.
For example: correct 03FF incorrect OX03FF

11.5. Verify Fails

a

If you have programmed new security passwords, the algorithm may no longer be able to unlock the
CSM using the default passwords. To avoid having to change the CSM passwords for different
operations, it is suggested that the CSM passwords be left erased (FFFFs) for initial development.
Refer to section 8 Code Security Module (CSM) Password Considerations if you have changed your
passwords from the default (erased) value.

Try increasing the wait states used for the flash during the verify operation as described in section 9.2
Configure Flash and OTP wait states: Verify User Option 1 and Verify User Option 2.

11.6. Programmed Application Fails To Run

This section offers suggestions if you find that your programmed .out file is not executing properly.

a

C2804x C/C++ Header Files and Peripheral Examples in C will be available for download from the
T1 website in 3Q06 and will provides small example programs for each of the peripherals on the
F2804x devices. Also included is an example flash project (in the examples\flash directory) that can
be followed as an example program that runs from Flash.

Running an Application from Internal Flash Memory on the TMS320F28xx DSP, literature #
SPRA958, is available for download from the Tl website. This application note goes over the
requirements for executing an application out of Flash memory. DSP/BIOS and non-BIOS
applications are both included.

Constant sections such as .switch, .const/.econst should be linked to page 0 (program) memory.
SDFlash will not program sections linked to page 1 (data) memory. Note: this was not the not the
case in C281x C/C++ Header Files and Peripheral Examples in C V.58, literature # SPRC097. If you
use these examples, move the .econst section to page 0. Refer to the linker section in the
TMS320C28x Assembly Language Tools User’s Guide, literature #SPRU513, for more information on
section allocation.

If using the boot ROM then check that the boot mode option 1/O pins of the device are set for “boot to
flash” operation. Refer to TMS320x280x, x2801x, x2804x Boot ROM Peripheral Reference Guide,
literature # SPRU722, for more information.

The 3.3V flash power pin, VDD3VFL, should remain connected, as it is required for read operations
as well as programming.
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a The location 0x3F7FF6-0x3F7FF7 in flash should be programmed with a branch instruction to re-
direct code flow from the boot ROM to the start of code in flash. The flash example program in
C281x C/C++ Header Files and Peripheral Examples in C, literature # SPRC097, illustrates how to
set this up.

a For programs with a long C initialization routine, the watchdog may reset before the main function is
reached and the watchdog disabled or serviced. In this case a small assembly routine can be
inserted in the code to disable the watchdog before the branch to _c_int00. The examples in C281x
C/C++ Header Files and Peripheral Examples in C, literature # SPRC097, illustrate how to disable
the watchdog before the c initialization phase.

a For programs with a long C initialization routine, the watchdog may reset before the main function is
reached and the watchdog disabled or serviced. In this case a small assembly routine can be
inserted in the code to disable the watchdog before the branch to _c_int00. The examples in C2804x
C/C++ Header Files and Peripheral Examples in C will be available for download from the TlI
website in 4Q06 illustrate how to disable the watchdog before the c initialization phase.
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To communicate back to the calling application, the API returns the following status messages. These

status values will be reported by SDFlash.

Status | Definition

Notes

0 STATUS_SUCCESS

Operation was successful.

10 | STATUS_FAI L_CSM LOCKED

The API function is unable to access the flash
array due to a locked Code Security Module.

11 STATUS_FAI L_REVI D_I NVALI D

The REVID is incorrect for this API.

12 STATUS_FAI L_ADDR | NVALI D

An invalid address (outside of the flash or
OTP bank) was passed to the API.

For the program operation, this could be
caused if the first address specified is outside
of flash/OTP or the number of words to be
programmed is such that the last address will
be outside of flash/OTP.

This error can be returned by the erase and
depletion recovery functions if an invalid
address is used for the pre-conditioning of the
flash. In this case check that the .const
section of the API is located in SARAM that
can be accessed by the API. This section
contains important information that is used by
the erase and depletion recovery functions.

In the case of this error, none of the values
passed to the program function will be
programmed. The flash status structure
(FLASH_ST) is not updated with any
information.

13 STATUS_FAI L_| NCORRECT_PARTI D

The expected PARTID did not match the
device PARTID. This would indicate that the
wrong API was used. For example, using a
TMS320F2812 APl on the TMS320F28044
device.
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Status

Definition

Notes

14

STATUS_FAI L_API _SI LI CON_M SNMATCH

At the start of each API function, the content of a
boot ROM location 0x3FFFB9 is checked to
determine if the API is ok to execute on that silicon.
In the future, Tl can change the content of this boot
ROM location if an APl becomes obsolete. This
will prevent an old API from executing on the new
silicon.

If this error code occurs, verify that that the proper
API version is being used. Check the
TMS320C2000 web site at
http://www.ti.com/c2000.

Erase Specific Status Messages

Erase had nothing to do because no valid sectors

20 STATUS_FAI L_NO_SECTOR_SPECI FI ED o
- - - - were specified.
21 STATUS_FAI L_PRECONDI T ON Erase operation failed bgcauge the clear portion of
the pre-condition operation failed.
Erase operation failed because the sector could
22 STATUS_FAI L_ERASE not be erased with the maximum allowed number
of pulses.
23 STATUS FAI L COVPACT Erasc_a_op_eratmn faﬂed_becaqse the post-
- - conditioning (compaction) failed.
Erase operation failed because the pre-
compaction portion failed. The pre-compaction is
24 STATUS_FAI L_PRECOVPACT applied to all sectors on the device. The

FLASH_ST structure will return a fail address
corresponding to the first sector fails this step.

Program Specific Status Messages

Program operation failed because one or more

30 STATUS_FAI L_PROGRAM .
bits could not be programmed.
Program operation failed because one or more
bits were already programmed (0) that should

31 STATUS FAI L_ZERO BI T_ERRCR have been erased (1). If this happens it could be

because the sector was not erased before
attempting to program.

Verify Specific Status Messages

40

STATUS_FAI L_VERI FY

The verify operation failed because one or more
bits did not match the reference data.
Try increasing the Flash or OTP wait states.

SDFlash

Specific Status Messages

144

M ssing clock detect bit set

This is a F2804x SDFlash specific error code. It is
issued by the SDFlash interface function, not the
flash API.

This error code indicates that the MCLKSTS bit is
set within the PLLSTS register. This bit indicates
that the external clock has at some point gone
missing. When this is the case, the flash API
should not be executed as it will be at the wrong
frequency.
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