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SDFlash Algo Disclaimer
Please check the Spectrum Digital website for future updates.

The SDFlash Algorithm files in this download include the following Flash Application
Program Interface (Flash API) libraries:

o F28235 V2.10: Flash28235_API_V210.lib
o F28234 V2.10: Flash28234_API_V210.lib
o F28232 V2.10: Flash28232_API_V210.lib

Texas Instruments Inc. (Tl) reserves the right to update or change any material included with
this release. This includes:

a The API functional behavior based on continued TMS320F2823x testing.
aImprovements in algorithm performance and functionality.

It is the user’s responsibility to check for future updates to the SDFlash Algo Files based on
any updates to the F2823x Flash APIs and to use the latest version available for their F2823x
silicon.

Updates to the API will be posted on the Texas Instruments Inc website (www.ti.com) and
can also be obtained by contacting Texas Instruments’ support. Updates to the SDFlash
algorithm files will also be posted on the Spectrum Digital website
(www.spectrumdigital.com).
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1. Revision History

This is the revision history for the F2823x algorithm builds for SDFlash. Note that the SDFlash algorithm build
version is separate from the SDFlash front-end utility version.

Version 1.0
O Initial release — supports only TMS320F28235 device.
Version 2.0

O Updated TMS320F28235 device algorithm to support new PARTID/CLASSID numbering system.
O Added support for TMS320F28234 and TMS320F28232 devices.

Version 2.1

O Corrected erase function of TMS320F28234 and TMS320F28232 devices.

2. Release Notes

O The flash APIs used in this release are available on the Tl website. Please check the Tl website for future
updates to the APL.

U Some traditional programming utilities have separate operations for “Clear” and “Erase”. These two
operations have been combined into one operation referred to only as “Erase”.

O Note: The CSM will be permanently locked if the CSM password locations are loaded with all 0x0000
and the device is secured. During the combined “Erase” function, a sector clear is immediately
followed by an erase operation without resetting the device. This will help avoid permanently
locking the CSM. Do not program the CSM passwords with all 0x0000.

SDFlash does not support the XDS560 scan controller.

O You should not run SDFlash and Code Composer at the same time. This results in two different
applications trying to control the DSP. During programming, SDFlash will have complete control of the
device. No user application code can be running in parallel.

3. Known Limitations

O SDFlash only programs sections linked to page 0 (i.e. program) memory. It is important to make sure that

sections such as .switch, and .const/.econst section are linked to page 0 and not page 1 for SDFlash to

program it.

Q When specifying User Options for SDFlash functions do not use a leading Ox in front of the number. Enter
only the hex value with no leading Ox. For example: correct: 03FF incorrect: 0x03FF
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4. API Revision vs. Silicon Revision

The silicon revision can be determined by the lot trace code marked on the top of the package. Refer to the device
specific errata for information on how to determine your device’s silicon revision from the device symbolization. In
addition, the silicon revision can be read from the REVID register located at address 0x883 as shown in the tables
below.

SDFlash Algo release information for F2823x:

Second Letter In REVID Obsolete Recommended
Prefix of Trace Lot | (Addr 0x883) SDFlash JTAG Algorithms SDFlash Version
Code
Blank 0x0000 none V2.1 or Later
A 0x0001 V1.0, V2.0 V2.1 or Later
Note:

For future silicon revisions, Tl anticipates that no functional changes will be required to these
APIs (and hence no changes should be required to SDFlash algorithms).

Should API changes occur that affect the programming of the flash, it is the user’s
responsibility to update any application that uses the API (programmers, embedded software,
etc) to insure proper long-term operation of the flash. Tl will test these APls on future silicon
revisions as soon as possible when such devices become available. Updates that only add
features are not required.

¢ TEXAS Texas Instruments Inc. 5
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5. SDFlash Overview

SDFlash is a generic front-end application owned by Spectrum Digital Inc (www.spectrumdigital.com). This
application provides a generic interface to the JTAG communications channel that can be used to support flash
programming.

In order to erase or program flash, SDFlash downloads a flash algorithm file onto the DSP. This algorithm file is an
executable (.out) file for the DSP being programmed and is executed on the DSP target. For the F2823x, the
SDFlash algorithm file consists of an SDFlash wrapper and the F2823x Flash API library. The SDFlash wrapper
has well defined standard functions and variables that are accessed by SDFlash over the JTAG channel. These
functions in turn make calls to the Flash API Library to perform operations on the flash array. Note: because the
SDFlash interface is separate from the algorithm file, the version of the SDFlash interface will differ from the version
of the algorithm file.

SDFlash X
Wrapper *
A .
v SARAM DSP
L)
Flash API Y Buffer PC
9 * Flash Data File
s N (.out to be
Q.g d
< SDFlash Algo programmed)
JTAG
Front-End \
CPU SDFlash
Algorithum File
OTP and
FLASH
ARRAY
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For SDFlash to erase or program the flash on a device, it must have

Flash Data the following information:
File O Location of the SDflash algorithm file
O Location of the flash data file — that is the data (.out file)
Algo File to program into the device.
SDFlash Project O Any user defined options.
(-sdp) O Which JTAG driver to use
Options Q Information about the JTAG scan chain
Communications All of this information is stored in an SDFlash project file (.sdp) that
Driver can be edited though the SDFlash GUI interface. A sample
SDFlash project for each F2823x device has been provided in this
download.

Section 6 of this document will guide you through the SDFlash setup and show you how to use the provided sample
SDFlash projects to create your own project and flash the F2823x device.

For example F2823x code that executes from the flash, refer to the following available from the Tl website:
O Device appropriate C/C++ Header Files and Peripheral Examples

Q Running an Application from Internal Memory on the TMS320F28xx DSP (SPRA958)

6. Quick Start Guide
The following is a step-by-step guide for using the SDFlash utility for 28xx.
This quick start guide will refer to the following default directory locations:

<CCS> default Code Composer Studio install directory: "c:\CCStudio_v3.3"
<SDFlash> default SDFlash directory <CCS>\specdig\SDFlash

These directories may be different for your particular installation.
6.1. Make sure the target and emulator are setup properly:
e If you are using an XDS510/XDS510pp+/SPI1515 emulation controller, use the SDConfig utility. The

SDConfig is part of the default emulation installation and will be installed in your
<CCS>\specdig\sdconfig directory

¢ TEXAS Texas Instruments Inc. 7
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6.2. Install the SDFlash flash support utility.
SDFlash will typically be installed in your <CCS>\specdig\SDFlash directory.
SDFlash is a generic utility supplied by Spectrum Digital Inc. to interface to user written algorithms. In
this case, Texas Instruments Inc has supplied the algorithm file. Users should check the SD website for
updates to this utility.

6.3. Download the latest F2823x SDFlash algorithm files.

Upgrades will be available for download from the Spectrum Digital website at
http://emulators.spectrumdiqgital.com/utilities/

CAUTION

The current version of the algos is considered beta material for initial sampling.
Please check Spectrum Digital’s website for future updates.

6.4. Unzip the F2823x SDflash algorithm files into the myprojects subdirectory of SDFlash. For a
typical install this will be the <CCS>\specdig\SDFlash\myprojects directory.

This will automatically create a directory indicating the processor and = [0 CCStudio_v3.3
version of the utilities. = ) specdig
=l | =dflash

Note: If you had installed an earlier release of SDFlash on your = [5) mvprojects
system you may have additional sub-directories to those shown, 3 [0 tifz82ax vz 0
such as an algo directory. With the release of SDFlash V1.3 the algo -

. . . - d
directory was replaced with the myprojects directory. Presence of . j F;:la:232
this directory will not effect the operation of SDFlash.

+ | Feaz34
6.5. Run SDFlash. # | ) fzgz3s

Load the supplied SDFlash sample project. SDFlash uses project files to store information required
to erase a device and program an .out file into a device. Sample projects have been included in the
installation for use as project templates.

Using File->Open Project in SDFlash, browse to and load the appropriate sample SDFlash project.
These sample projects program a flash image that is an address = data pattern. The CSM password is
not programmed. For a typical installation, these files will be found in the following location:

F28235: <SDFlash>\myprojects\tif2823x_v2_1\f28235\SampleF28235eZdspusb.sdp
F28234: <SDFlash>\myprojects\tif2823x_v2_1\f28234\SampleF28234eZdspusb.sdp
F28232: <SDFlash>\myprojects\tif2823x_v2_1\f28232\SampleF28232eZdspusb.sdp
¢ TEXAS Texas Instruments Inc. 8
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6.6. Modify the SDFlash project (if required) to locate the various elements such as device driver,
algorithm file and flash data file.

If you installed Code Composer Studio (CCS) and SDFlash in the <CCS base> and <SDFlash base>
directories shown below, then usually only the Flash Data File on the Program Tab, and possibly the
Emulator Address/ID on the Target Tab needs to be changed.

By default all flash projects are setup relative to the default Code Composer Studio 3.3 base directory
"CCStudio_v3.3". For example:

<CCS> default Code Composer install directory: "CCStudio_v3.3"

<SDFlash> default is <CCS>\specdig\SDFlash

SDFlash binary default is <CCS>\specdig\SDFlash

Flash projects default is <CCS>\specdig\SDFlash\myprojects\<projectname>
NOTE

The location of the SDFlash directories may be different for your particular installation.
For example, the <CCS base> directory for some older Code Composer Studio
installations will be c:\ti\ or ¢c:\CCStudio_v3.1\.

In this case, the SDFlash project will need to be updated to reflect the directory
structure of your install.

To change any of the directory paths or project settings from their default values, open
the project settings dialog box: Project->Settings

To change any of the directory paths or project settings from their default values, open the project settings
dialog box: Project->Settings

The fields that require directory paths in the Project->Settings window are summarized below:

Target Tab: Erase Tab: Programming Tab: Verify Tab:
-Driver -Algorithm File -Algorithm File -Algorithm File
-Board File -Flash Data File

Target Tab:

Q Driver: This is the Code Composer Studio"™ emulation driver (*.dvr) file that is used to communicate
with the target. The driver files can be found in the <CCS>\drivers\ directory.

default for other 510PP+/SPI515 etc:  <CCS>\drivers\sdgo28x.dvr

Q Emulator Address/ID: default is 378 for the 510pp, it is 510 for the USB driver. This address must
match the setting in your SDConfig setup.

Q Board file: File that provides SDFlash information on how many devices are on the JTAG scan
chain. For a single 28x device on the scan chain, the default board file can be used. For systems
with more devices on the scan chain, use the board file generated by Code Composer Studio to
access your device. This file is found in the <CCS>\cc\bin\BrdDat directory.

The default board file is <SDFlash>\myprojects\tif2823x_v2_1\ccBrd028x.dat

O Processor name: default is cpu_0

¢ TEXAS Texas Instruments Inc. 9
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Erase Tab:

a Algorithm File:
F28235: <SDFlash>\myprojects\tif2823x_v2_1\f28235\flash28\Debug\SDFlash28235_erase.out
F28234: <SDFlash>\myprojects\tif2823x_v2_1\f28234\flash28\Debug\SDFlash28234_erase.out
F28232: <SDFlash>\myprojects\tif2823x_v2_1\f28232\flash28\Debug\SDFlash28232_erase.out

Q Timeout: leave as 3000

Q User Options 1: Erase sector mask default is 00FF.
See section 9 for more information.

Q For all other boxes the default is blank.

Program Tab:
a Algorithm File:

F28235: <SDFlash>\myprojects\tif2823x_v2_1\f28235\flash28\Debug\SDFlash28235_program.out
F28234: <SDFlash>\myprojects\tif2823x_v2_1\f28234\flash28\Debug\SDFlash28234_program.out
F28232: <SDFlash>\myprojects\tif2823x_v2_1\f28232\flash28\Debug\SDFlash28232_program.out

Q Flash Data File: This is the .out file that you want to program into the flash. The sample image
provided with the algorithm is a simple data = address pattern. The code security module
password locations are not programmed by the sample image. That is, the CSM password
locations are left erased (all 0xXFFFF’s) so that the CSM can easily be unlocked.

If you have your own .out file ready to be programmed you can specify that file as the data file.
The sample image Flash Data File is located at:

F28235: <SDFlash>\myprojects\tif2823x_v2_1\f28235\image\Debug\image28235.out

F28234: <SDFlash>\myprojects\tif2823x_v2_1\f28234\image\Debug\image28234.out

F28232: <SDFlash>\myprojects\tif2823x_v2_1\f28232\image\Debug\image28232.out
Q Timeout:leave as 3000

Q For all other boxes the default is blank.

Verify Tab:
a Algorithm File:

F28235: <SDFlash>\myprojects\tif2823x_v2_1\f28235\flash28\Debug\SDFlash28235_verify.out
F28234: <SDFlash>\myprojects\tif2823x_v2_1\f28234\flash28\Debug\SDFlash28234_verify.out
F28232: <SDFlash>\myprojects\tif2823x_v2_1\f28232\flash28\Debug\SDFlash28232_verify.out

Q Timeout: leave as 3000

Q User Options 1: Flash wait states: default is OFOF

O User Options 2: OTP wait states: default is 001F

Q For all other boxes the default is blank.

¢ TEXAS Texas Instruments Inc. 10
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6.7.

6.8.

6.9.

6.10.

6.11.

Save the SDFlash project file: File->Save Project As. Once you have made the required changes
select ok and save the project using the name of your choice: File->Save Project As.

If you changed the Emulator Address/ID setting on the Target Tab, you should get a message that the
current driver was unloaded and a new driver has been loaded. This operation is required to
synchronize the SDFlash project settings with SDConfig. If you did not change the Emulator
Address/ID, then you will not get this message.

You have now created an SDFlash project that can be used anytime you want to erase or program the
device using these settings. Should you want to program a different .out file into the F2823x flash, use
this project as a template and change the Flash Data File on the Program Tab.
Configure the algorithm for the required PLL multiplier and CPU frequency.

For custom CPU frequency and PLL multiplier, you must follow the instructions in section

7 to properly configure the algorithms before continuing. As supplied, the algorithm is

configured for:

PLLCR = 0x000A (PLL x10/2 mode), and CPU frequency = 150MHz

CAUTION
The erase and program operations MUST be configured for the CPU clock rate
(SYSCLKOUT) at which they will run. This configuration is VITAL for proper
operation of the algorithm.
As supplied, the algorithm is configured for:

PLLCR = 0x000A (PLL x10/2 mode), and CPU frequency = 100MHz

For custom CPU frequency and PLL multiplier, you must follow the instructions in
section 7 to properly configure the algorithms before continuing.

Optional: View which sections are going to be programmed (i.e. loaded) using the
View->Coff/Hex file stats SDFlash function.

O Make sure that no RAM locations are marked as load sections.

0 Constant sections (i.e. .const/.econst) must be linked to page 0 (i.e. program memory) for
SDFlash to program them.

O Itis suggested to not program the CSM password locations (0x33FFF8-0x33FFFF) during
development since flash contents will be changed often. Note that these addresses are different
in the F2823x devices than they were in the F281x, F280x, and F2804x devices.

a If programming the OTP, note that it can only be programmed once. It cannot be erased.

Reset the device: Device->Resel. You will get a pass/fail message in the output window.
Erase/Program/Verify your device: Device->-Flash. Check or un-check the operation(s) you want to

perform then select start. Each checked operation is executed from left to right, with continue on
success and abort on fail. Refer to Section 11 for tips should a failure occur.

¢ TEXAS Texas Instruments Inc. 11
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CAUTION

Do not press the SDFlash STOP button during the erase operation.
Pressing STOP will halt the CPU before the Erase algorithm completes. This can leave
the Flash in a depleted state or result in unknown Code Security Module passwords
and lock the device permanently.
Other conditions that can cause the CPU to halt prior to the completion of the Erase
algorithm (e.g., power loss, device reset, PC crash, etc.) can result to the same problem
described above.

Pressing STOP when executing the frequency toggle test described in section 9.3 is ok.

6.12. Optional: Repeat erase/programming for each device to be programmed. If additional devices are
to be programmed, the target can be powered down and a new target connected without closing the
SDFlash utility. Once the new target is connected, reset the part (Device->Reset) and erase, program,
verify (Device->Flash) the device as described in 6.10 and 6.11.

6.13. Optional: View the flash contents using Code Composer Studio™ (CCS). You can view the
programmed flash using CCS, and compare with your source code.

Make sure that the SDFlash utility is closed before starting CCS.

Start CCS and open a memory window to view the flash contents (or use the disassembly window). In
addition you can load the CCS project and load the symbols from the .out file.

¢ TEXAS Texas Instruments Inc. 12
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7. PLL and CPU Clock Rate Configuration

CAUTION

The F2823x Flash API used by SDFlash contains several delay parameters that
are implemented as software delays. Timing of these delays is VITAL to proper
operation. To ensure the proper delays, the flash algorithms must be run at the
correct speed.

As shipped, the algorithms are configured for the following:

30 MHz input clock

x10 PLLCR (0x000A)

Y2 CLKINDIV enabled

This results in a 150 MHz CPU clock (SYSCLKOUT)

If your hardware requires any of the following:

a different CPU rate (SYSCLKOUT) then 150MHz

or requires a different PLLCR setting then 0x000A

or requires the PLL to be disabled

or requires that CLKINDIV is set (1/2 disabled in this case PLLCR must
be set to 0x0000)

then you must modify and re-compile the flash programming algorithms for
your system’s specific requirements as described below:

The following steps describe how to compile a new SDFlash algorithm file for a custom frequency and
PLL Control Register (PLLCR) setting.

Using Code Composer Studio (CCS), load the projects for your device. There is one project per

operation and all must be re-compiled for the new PLL configuration. These are the CCS projects
used to build the SDFlash algorithm files. The projects are:

F28235: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28235\flash28\

SDFlash28235_Erase.pjt, SDFlash28235_Program.pijt,
SDFlash28235_Verify.pjt SDFlash28235_DepRecover.pjt

F28234: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28234\flash28\
SDFlash28234_Erase.pjt, SDFlash28234_Program.pijt,
SDFlash28234_Verify.pjt SDFlash28234_DepRecover.pjt

F28232: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28232\flash28\
SDFlash28232_Erase.pjt, SDFlash28232_Program.pjt,
SDFlash28232_Verify.pjt SDFlash28232_DepRecover.pjt

¢ TEXAS Texas Instruments Inc. 13
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7.1.

7.2.

Specify the required PLLCR (PLL Control Register) value.

In CCS, open and modify SDFlash2823x_Wrapper.h to specify the PLLCR (PLL Control Register)
value. Uncomment the line corresponding to the required PLL Control Register (PLLCR) setting. This is
done by removing the leading // in front of the correct line. Only one line should be uncommented.

For example: To have the algorithms initialize the PLLCR register to 0x0009 uncomment the second
line and comment out the remaining lines as shown:

// #define PLLCR_VALUE O0x000A // SYSCLKOUT = (OSCLK*10)/2
#define PLLCR_VALUE 0x0009 // SYSCLKOUT (OSCLK*9) /2
// #define PLLCR_VALUE 0x0008 // SYSCLKOUT = (OSCLK*8) /2

Specify the clock rate of the CPU (SYSCLKOUT) in nanoseconds. In CCS, open and modify the
API configuration file Flash2823x_API_Config.h to specify the clock rate of the CPU (SYSCLKOUT) in
nanoseconds. This is done by removing the leading // in front of the correct line. Only one line should
be uncommented. The file lists a number of commonly occurring clock rates. If your CPU clock rate is
not listed, then provide your own definition using the examples as a guideline.

For example: Suppose the final CPU clock rate will be 125 Mhz. This corresponds to a 8 nS cycle
time. There is no line present for this clock speed, so you should insert your own entry and comment
out all other entries:

//#define CPU_RATE 6.667L // for a 150MHz CPU clock speed (SYSCLKOUT)
#define CPU_RATE 8.000L // for a 125MHz CPU clock speed (SYSCLKOUT)

//#define CPU_RATE 10.000L // for a 100MHz CPU clock speed (SYSCLKOUT)
//#define CPU_RATE 13.330L // for a 75MHz CPU clock speed (SYSCLKOUT)

CAUTION
For flash integrity at operating frequencies, the device should always be programmed
at the fastest possible CPU frequency. For example, if the CLKIN frequency is 30 MHz
program the device at 150 MHz rather then 30 MHz or 60 MHz.

The flash utilities are not designed to function properly below 10 MHz.

¢ TEXAS Texas Instruments Inc. 14
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7.3.

7.4.

7.5.

7.6.

If your system requires any other custom setup such as modifying the CLKINDIV bit then:
Open the SDFlash2823x_Main.c file. The code that is executed on startup to setup the PLL is at the
beginning of the main() function within this file. Modify this function as required for your clock
requirements.

Rebuild each of the algorithms in CCS by selecting Project->Rebuild all.

CAUTION

It is important to rebuild all of the algorithm files: erase, program, verify and depletion
recovery.

Exit Code Composer Studio

Run the CPU frequency and PLL multiplier configuration toggle test described in section 9.3
from SDFlash to verify the configuration.

When run, this test will toggle a selected GP 1/O pin at a known frequency. This will allow you to
confirm that the algorithms are properly configured for the CPU frequency and PLL multiplier you
specified.

CAUTION

It is strongly recommended that you test the CPU frequency and PLL configuration
using the configuration toggle test described in section 9.3 before erasing or
programming any parts.

If this test fails, DO NOT PROCEED to erase or program the flash until the problem is
corrected, or flash damage can occur.

The SDFlash algorithm file should now be configured for your hardware’s frequency requirements.

¢ TEXAS Texas Instruments Inc.
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8. Code Security Module (CSM) Password Considerations

The F2823x SDFlash algos must unlock the Code Security Module (CSM) before an erase, program, or verify
operation. As supplied, the password locations are assumed to be all erased (all OxFFFFs). During the code
development phase, it is suggested that the CSM passwords be left erased (0xFFFFs) for ease of use. If you
program new passwords into the CSM password locations (0x33FFF8-0x33FFFF) and then later need to re-
program the part, you will need to configure the flash algorithms so that the CSM can be unlocked. Refer to
TMS320x2833x, 2823x System Control and Interrupts Peripheral Reference Guide (SPURFBO), for details on
the proper operation of the CSM. Note that the addresses of the CSM password locations are different on the
F2823x devices than they were on the F281x, F280x, and F2804x devices.

The algorithm uses the CSM keys provided in the appropriate CSM key assembly file:
(SDFlash28x_Erase_CsmkKeys.asm, SDFlash28x_Program_CsmKeys.asm, or
SDFlash28x_Verify_CsmKeys.asm) to unlock the CSM. Follow these steps to build an SDFlash algorithm file
with a new set of CSM passwords.

8.1. Using Code Composer Studio (CCS), load the projects for your device. There is one project per
operation and all must be re-compiled for the new PLL configuration. These are the CCS
projects used to build the SDFlash algorithm files. The projects are:

F28235: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28235\flash28\

SDFlash28235_Erase.pjt, SDFlash28235_Program.pijt,
SDFlash28235_Verify.pjt SDFlash28235_DepRecover.pjt
F28234: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28234\flash28\
SDFlash28234_Erase.pijt, SDFlash28234_Program.pijt,
SDFlash28234_Verify.pjt SDFlash28234_DepRecover.pjt
F28232: Install Dir: <SDFlash>\myprojects\tif2823x_v2_1\f28232\flash28\
SDFlash28232_Erase.pjt, SDFlash28232_Program.pijt,
SDFlash28232_Verify.pjt SDFlash28232_DepRecover.pjt

8.2. In CCS, open the appropriate CSM key file: SDFlash28x_Erase_CsmKeys.asm,
SDFlash28x_Program_CsmKeys.asm, or SDFlash28x_Verify_CsmKeys.asm. These files contain
the definition of the CSM passwords used by the algorithm to unlock the CSM during the erase,
program and verify operations.

Note: The passwords in this file will not be programmed into the CSM password locations. The
algorithm uses these passwords only to unlock the CSM prior to an erase, program or verify operation.

8.3. Modify the passwords in the appropriate CSM key file to match those already programmed into
the CSM password locations.

8.4. Rebuild the algorithms in CCS by selecting Project->Rebuild All
8.5. Exit Code Composer Studio
Note: Each step in the process Erase, Program, and Verify separately unlocks the CSM. If you are changing

the passwords during the Program operation, you will need to supply the new passwords for the verify
operation by following the steps above.
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9. SDFlash User Options

The SDFlash utility provides user options for each operation: Erase, Program and Verify. The function implemented
by each of the user options is dependent on the algorithm being interfaced to.

The following table shows an overview of which user options are used by the F2823x SDflash algorithm V1_0.

Erase Program Verify
User Option 1 | Sector Mask Not used Flash bank wait states
User Option 2 | Not used* Not used OTP wait states
User Option 3 | Run frequency toggle test | Run frequency toggle test | Run frequency toggle test
User Option 4 | Not used Not used Not used

* Note on 281x devices this was the frequency toggle test. This has been moved to the user option 3. The
frequency toggle test is available under all operations since each operation algorithm file is a separate compile.

The following sections describe in detail how to use each option.

CAUTION

When entering the User Options into the SDFlash interface, do not use a leading 0x.
Enter only the hex digits as shown in the examples provided.

9.1. Specify Which Sectors to Erase: Erase User Option 1

For the erase operation, User Option 1 allows you oS A G G R T = = %]
to select which sectors will be erased. This - T -

information is provided in the form of a mask value Target Eraze F'n:.gramming] Werify ]

where a set bit indicates that the sector will be

erased. Algarithm File:

|EEEH_VE_U"JEEEEE"-.f|aSh28"-.D ebughSDFlash28235_Erase.out J
F28235

Bit 0 = Erase Sector A
Bit 1 = Erase Sector B
Bit 2 = Erase Sector C

Bit 3 = Erase Sector D Timeout: |3000 70 |
Bit 4 = Erase Sector E
Bit 5 = Erase Sector F ATt |
Bit 6 = Erase Sector G ;

; . |0OFF Pr5T:
Bit 7 = Erase Sector H Ulsizs Do |
Bit 8-15 = ignored Izer Options 2: FMST Address: |
To modify the sector mask value: User Options 3

Izer Options 4:
9.1.1. Open the project settings:
Project -> Settings

9.1.2. Click on the Erase tab ok | Cancel Help

¢ TEXAS Texas Instruments Inc. 17
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9.1.3. Enter a mask value for User Option 1 that corresponds to the sectors you want erased. Enter the hex
number digits only.
Do not enter a leading 0x. For the example shown: Erase User Option 1 = 00FF would erase all sectors on
a F28235 device.

9.1.4. Select OK and save the project: File->Save Project

CAUTION
The One Time Programmable Block (OTP) can only be programmed once.
The OTP block cannot be erased.

CAUTION
Do not press the SDFlash STOP button during the erase operation.
Pressing STOP will halt the CPU before the Erase algorithm completes. This can leave the Flash in a
depleted state or result in unknown Code Security Module passwords and lock the device
permanently. If you feel your device is in a depleted state (cannot be erased) then try the depletion
recovery algo.

Other conditions that can cause the CPU to halt prior to the completion of the Erase algorithm (e.g.,
power loss, device reset, PC crash, etc.) can result to the same problem described above.

Pressing STOP when executing the frequency toggle test described in section 9.3 is ok.

F28235 Sector Mask Value: F28235 Sector Addresses:

Bit 0 = Erase Sector A
Bit 1 = Erase Sector B
Bit 2 = Erase Sector C
Bit 3 = Erase Sector D
Bit 4 = Erase Sector E
Bit 5 = Erase Sector F
Bit 6 = Erase Sector G
Bit 7 = Erase Sector H
Bit 8-15 = ignored

F28235 Erase User Option 1 Examples:

‘9 TEXAS
INSTRUMENTS

ADDRESS RANGE

PROGRAM AND DATA SPACE

Dx30 0000 - 030 TFFF

Sector H (32K x 18)

0x20 2000 - 0x30 FFFF

Sector G (32K x 18)

Dx31 0000 - 031 TFFF

Sector F (32K x 18)

0x31 2000 - 0x31 FFFF

Sector E (32K = 18)

0«32 0000 - 032 TFFF

Sector D (32K = 18)

0x32 5000 - 0x32 FFFF

Sector C (32K x 18)

0>:33 D000 - D33 YFFF

Sector B (32K x 18)

Dx33 BODO - 032 FFTF

033 FFa0 - Ox33 FFFS

0x33 FFFE - 033 FFFT

0x33 FFF8 - Ox33 FFFF

Sector A (32K x 18)

Program to 0x0000 when using the
Code Security Module
Boot-to-Flash Entry Paoint
(program branch instruction here)
Security Password
(128-Bit) (Do Mot Program to all zeros)

0001  Erase only sector A

0003 Erase only sector A and sector B
00FF Erase all sectors on an F28235 device

Texas Instruments Inc.
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9.2. Configure Flash and OTP wait states: Verify User Option 1 and Verify User Option 2

Verify User Option 1 and User Option 2 allows you to specify Verify

wait states used for the Flash and OTP memory during the User Option 1 Flash bank wait states

verify operation. This option can be used to increase the speed | US€rOption2 | OTP wait states
of the verify operation or allow you to match the wait states used | User Option3 | Toggle test (section 9.3)

in your application if desired. User Option 4 Not used

CAUTION:

Frequency limits for both the Flash and OTP blocks are documented in the device
Data Manual (SPRS439). Refer to the Data Manual for the minimum access time of
the Flash and OTP memory. Using a wait state value that is too low will cause the
verify operation to fail.

Verify User Option 1 specifies the Flash waitstate register (FBANKWAIT) contents:

12 | 1 g |7 s | = 0
| Ressrved PAGEWAIT Reserved RANDWAIT |
R-0 RAW-1 R-0 RAW-1

FBANKWAIT Register

The sample SDFlash project uses the default value of OFOF. This value is also used if the option is left blank.

Verify User Option 2 specifies the OTP waitstate register (FOTPWAIT) contents:

15 | | g 4 I 0
FOTPWAIT Register | Reserved | OTPWAIT |
R-0 RMWN-1
PSOREMURCONTROIBERRINGD 2 ][x]
The sample SDFlash project uses the default
value of 001F. This value is also used if the Target] Erase ] Programming  erify
option is left blank.
Algarithrn File:
To set the wait state values: |823H_vz_mf28235af|ashzsmebugasDF|ash28235_verify.nut J
9.2.1. Open the project settings: Project -> Ti v 3000
Settings e
9.2.2. Click on the Verify tab User Optians 1: |OFOF ST |
9.2.3. For User Options 1 enter the value for the User Options 2 |P91F ST |
FBANKWAIT register User Options 2 PRST: |
9.2.4. For User Options 2 enter the value for the Ulzer Options & PMST Address: |
FOTPWAIT register
9.2.5. Select OK
9.2.6. Save the project: File->Save Project
k. | Cancel Help
] Texas Instruments Inc. 19
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9.3. CPU Frequency and PLL Multiplier Configuration Toggle Test: User Option 3

User Option 3 turns on and off the frequency configuration toggle test. This test is used to confirm that the
algorithms are properly configured for the CPU frequency and PLL multiplier. Refer to section 7 for information on
how to configure the algorithm for the frequency of your CPU.

The toggle test is available as user option 3 for erase, program and verify because the algorithm file for each of the
operations is a separate compile. At initial setup, it is recommended that the frequency configuration of at least the
erase and program operations are verified via the toggle test.

To run this test:
9.3.1. Open the project settings: Project -> Settings

9.3.2. Click on the appropriate tab: erase,

. S R L RGN G R F0. 1
program, Verlfy Pl PR LS SR | e B BEH ._JJ IFe .__J a

Target Erase | P ing | Werif
9.3.3. For “User Options 3”, enter the value that arae mgrammmg] E"y]

corresponds to the pin you want to toggle Algarithim File:
as shown in the table. Enter the value as

hex digits only. Do not enter a Ox in front |EEE:-:_VE_D'\fEEEEE"-.fIaSh28"-.[3ebug'xSDFIashEEESE_Erase.-:uut J
of the value.

In the example shown, 0022 in erase

User Options 3 indicates that the toggle Timeawt; | 3000 _

test will be run on GP1034 instead of the aTo: |

erase operation. 571 |
E Pin T ied Ilser Options 1: |OOFF PMST: |

rase, in Toggle _ _
Program and | (100uS cycle time) User Options 2: PMST Address: |
Verify . User Options 3 |122
User Option 2 _ li
blank Test not run User Options &:
0000 GPIO0
0001 GPIO1
0002 GPIO2 Ok | Cancel Help
0003 GPIO3 -
0004 GPIO4
0005 GPIOS...
000A GPIO10
0022 GPIO34
0023-FFFF Test not run
@ TEXAS Texas Instruments Inc. 20
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CAUTION

Choose an appropriate pin for your system. Check your board design and board
connections to be certain that the pin you have selected for toggling is not being
driven by a source other than the DSP, or voltage contention can occur. Also, be
certain that whatever the toggling pin is connected to in your system will not
encounter difficulty when the pin is toggling (e.g., the device the pin is connected to
should be powered-down, held in reset, etc.). A number of different pins are selectable
above in order to avoid such problems,

9.3.4. Click Ok and save the project: File->Save Project

9.3.5. To begin the toggle test, start a SDFlash operation using the Device->Flash menu.

Uncheck any operations you are not using. For example, if you want to check the frequency configuration
of the program algorithm, uncheck the erase option and press start.

With User Option 3 set to 0000 - 0022, the toggle test will be performed instead of the specified operation
and SDFlash will eventually timeout. The timeout period is as specified in the Timeout box, in seconds
(e.g., 3000 seconds). The user can click Stop to halt the toggle test sooner.

While the test runs, monitor the selected pin using an oscilloscope. If the algorithms are configured
correctly for your CPU rate then the pin will toggle near 10kHz (100uS +/- 10uS cycle time).

If the pin is toggling at a different rate, then the algorithms are not configured correctly. Follow the
instructions detailed in section 7,

10. Depletion Recovery Algorithm

This release of the SDFlash utilities includes a depletion recovery algorithm. This algorithm is called instead of
erase for the following projects:

SampleF28235_DepRecover.sdp
SampleF28234_DepRecover.sdp
SampleF28232_DepRecover.sdp

Note: These sample projects are setup for depletion recovery only and do not contain code to perform a program or
verify operation. Thus, these operations will report a failure but do not perform any operation on the device.

How does depletion occur?

If the erase operation is interrupted and not allowed to complete the device may become depleted. When this
happens, the device may then begin to fail to erase. All efforts should be taken to not stop the erase algorithm as
this can also affect the CSM passwords. [f the passwords are in an unknown state then the device cannot be
recovered. If, however, the CSM passwords are known and the device can be unlocked, then the depletion
recovery algorithm can be run to try and recover the part.

The depletion recovery algo looks for sectors that are in depletion and attempts to recover them. All sectors on the
device are checked.

The current maximum timeout for the algorithm is approx 35 seconds per sector that is in depletion.

Typically only one sector would be in depletion unless erase has been called multiple times on multiple sectors
without running to completion. If a longer timeout can be tolerated, the depletion recovery can be used multiple
times.
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There is no guarantee that this algorithm will be able to bring a sector out of depletion within a reasonable amount
of time. The deeper in depletion the part is, the longer it will take to recover. The Flash API erase function

has been implemented to erase the flash in such a manner that it is not put into deep depletion. However, if the
CPU is halted during an erase pulse for a long period of time the part can be put into a deep depletion that may not
be recoverable in a time period that is acceptable.

This algorithm cannot recover the part if the flash passwords are unknown. For example if power is lost during the
erase of sector A, where the CSM passwords are located, then the device may be permanently locked and the
recovery algorithm cannot operate on the flash.
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INSTRUMENTS



TMS320F2823x SDFlash Programming Utilities F2823x SDFlash Algo V2.1

11. Troubleshooting Tips

This is a list of solutions to potential failures when using the SDFlash utility. At this point you should have the most
recent SDFlash revision installed and the proper flashing algorithms for the DSP you are using should be unzipped
in to your SDFlash\myprojects folder. Prior to using the SDFlash, the SDConfig utility must successfully run and
verify connection to your emulator and target DSP board. The SDConfig can be launched via the 'SDConfig' icon on
your Windows desktop. If you need help with the SDConfig, please refer to the SDConfig.htm file included in your
SDConfig directory.

It is recommended you begin by using one of the example projects included with the flashing algorithms associated
with the DSP you are using. Before attempting to erase or program the flash, check the Project Settings of the flash
project you are using. The project settings can be viewed by clicking the 'Project’ menu, then click 'Settings'. Verify
that each field that requires a directory path points to the location where that file is actually located. The fields that
require directory paths in the Project Settings Window are:

Target Tab: Erase Tab: Programming Tab: Verify Tab:
-Driver -Algorithm File -Algorithm File -Algorithm File
-Board File -Flash Data File

If you have installed the SDFlash and Algorithms in a directory different from the default installation directory, the
directory paths in the Project Settings will need to be changed.

11.1. DSP Reset Fails

O Check that the target DSP board is properly powered. Check that the DSP is properly clocked (check
XCLKOUT using an oscilloscope).

O If using a stand alone JTAG emulator, make sure that it is properly powered.
O Make sure that the SDFlash Project is configured for the correct driver and port address. The SDFlash
project must be configured with the correct driver to support the Spectrum Digital JTAG Emulator or

eZdsp board you are using.

11.2.  All Operations

Refer to section 12 for a description of the API error codes that will be reported by SDFlash.

The errors ‘File Does Not Exist' or 'Load file failed’ may appear when attempting to open the Flash
Panel. The file that the errors are referring to is the 'Flash Data File' located on the Programming tab of
the Project Settings. Verify the directory path to the COFF file you wish to load is a valid path. (i.e. that
the .out file exists in the directory entered.)

0 A successful 'RESET' in SDFlash means the JTAG Emulator and Target board are properly powered
and connected. However, take a moment to verify that all cables are connected securely and that the
proper power is supplied to the emulator and target board.

0 Older versions of the SDFlash algos are based on obsolete Flash APIs and should not be used.
0 Run SDConfig to make sure your target and emulator are setup properly.

0 Examine the project settings Project->Settings and make sure the path names to all files are correct as
described in section 6.6.
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O The flashing algorithms must be configured to multiply the DSP's input frequency appropriately and not

11.3.

exceed the DSP's maximum operational frequency. The algorithms found on the Spectrum Digital
support sites are configured to support Spectrum Digital target boards. If you are using a custom board
refer to the directions in this to properly configure the algorithms to support your target configuration.

Make sure SDFlash can unlock the Code Security Module (CSM). An SDFlash error message of "ERR:
Failed to initialize the algorithm" can indicate the CSM as the source of the problem. The algorithm
attempts to unlock the CSM before an erase, program, or verify operation. By default, the password
locations are assumed to be all erased (FFFFs). Refer to section 8 Code Security Module (CSM)
Password Considerations if you have changed your passwords from the erased value.

It is suggested that the CSM passwords be left erased (FFFFs) for initial development. Refer to the
TMS320x2833x, 2823x System Control and Interrupts Reference Guide for details on the CSM
operation.

If required, configure the SDFlash algorithms for a custom CPU frequency and PLL multiplier. As
supplied, the algorithms are configured for a CPU clock frequency (SYSCLKOUT) of 150MHz and to
set the PLLCR register to 0x000A. If your hardware has other requirements you must configure the
algorithms as described in section 7 Confirm proper configuration of the algorithms by running the CPU
frequency and PLL multiplier configuration toggle test described in section 9.3 CPU Frequency and PLL
Muiltiplier Configuration Toggle Test: User Option 3

SDFlash should have full control of the device. That is, no user application should be running, no
interrupts firing, and CCS should be shut down prior to using SDFlash.

Make sure that the device has a clean VDD3VFL 3.3V voltage source. In addition VDD3VFL should
remain connected, as it is required for read operations as well as programming.

Check the part using Code Composer Studio (CCS). Using CCS, check the SARAM blocks and make
sure that you can unlock the CSM (check by attempting to view the passwords in a memory window. If
you view all 0x0000's, the CSM is still locked).

Erase Fails

Make sure a valid sector mask is specified for User Option 1 for the erase operation. At least one
sector must be specified. Do not use a 0x in front of the mask value — simply enter the hex number
without the leading 0x. For example: correct 00OFF incorrect 0XO0FF

If the configuration toggle test is selected via erase User Option 2, then the toggle test is executed in
place of the erase algorithm. SDFlash will timeout and report an erase error in this case. Refer to
section 9.3 CPU Frequency and PLL Multiplier Configuration Toggle Test: User Option 3

for more information.

If you programmed new security passwords, the SDFlash algorithm may no longer be able to unlock the
CSM using the default passwords. To avoid having to change the CSM passwords for different
operations, it is suggested that the CSM passwords be left erased (FFFFs) for initial development.
Refer to section 8 Code Security Module (CSM) Password Considerations if you have changed your
passwords from the default (erased) value.
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11.4. Programming Fails

Q

Check to make sure you are not programming a region of memory outside of the flash. To see what
sections SDFlash will program, use the View->Coff/Hex File Status utility and look for sections
labeled “load” outside of the flash memory region. It may be that the start address is within Flash or
OTP but the end address is not.

Refer to the linker section in the TMS320C28x Assembly Language Tools User’s Guide, literature
#SPRU513, for more information on preparing your code for programming. Any loaded section that
starts outside or ends outside of the flash region will cause programming to fail.

Make sure you erased the sectors being programmed prior to programming them. Make sure the
sector mask used for the erase function did not include the leading 0x.
For example: correct 00FF incorrect 0XO0FF

11.5. Verify Fails

a

If you have programmed new security passwords, the algorithm may no longer be able to unlock the
CSM using the default passwords. To avoid having to change the CSM passwords for different
operations, it is suggested that the CSM passwords be left erased (FFFFs) for initial development.
Refer to section 8 Code Security Module (CSM) Password Considerations if you have changed your
passwords from the default (erased) value.

Try increasing the wait states used for the flash during the verify operation as described in section 9.2
Configure Flash and OTP wait states: Verify User Option 1 and Verify User Option 2.

11.6. Programmed Application Fails To Run

This section offers suggestions if you find that your programmed .out file is not executing properly.

Q

C2833x/C2823x C/C++ Header Files and Peripheral Examples are available for download from the
T1 website and provide small example programs for each of the peripherals on the F2823x devices.
Also included is an example flash project (in the examples\flash directory) that can be followed as an
example program that runs from Flash.

Running an Application from Internal Flash Memory on the TMS320F28xx DSP, literature #
SPRA958, is available for download from the Tl website. This application note goes over the
requirements for executing an application out of Flash memory. DSP/BIOS and non-BIOS
applications are both included.

Constant sections such as .switch, .const/.econst should be linked to page 0 (program) memory.
SDFlash will not program sections linked to page 1 (data) memory. Note: this was not the not the
case in C281x C/C++ Header Files and Peripheral Examples in C V.58, literature # SPRC097. If you
use these examples, move the .econst section to page 0. Refer to the linker section in the
TMS320C28x Assembly Language Tools User’s Guide, literature #SPRU513, for more information on
section allocation.

If using the boot ROM then check that the boot mode option 1/O pins of the device are set for “boot to
flash” operation. Refer to TMS320x2833x, 2823x Boot ROM Peripheral Reference Guide, literature
# SPRU963, for more information.

The 3.3V flash power pin, VDD3VFL, should remain connected, as it is required for read operations
as well as programming.
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a The location 0x33FFF6-0x33FFF7 in flash should be programmed with a branch instruction to re-
direct code flow from the boot ROM to the start of code in flash. The flash example program in
C2833x/C2823x C/C++ Header Files and Peripheral Examples, literature # SPRC097, illustrates how
to set this up. Note that this location is different in the F2823x devices than it was in the F281x,
F280x, and F2804x devices.

a For programs with a long C initialization routine, the watchdog may reset before the main function is
reached and the watchdog disabled or serviced. In this case a small assembly routine can be
inserted in the code to disable the watchdog before the branch to _c_int00. The examples in
C2833x/C2823x C/C++ Header Files and Peripheral Examples are available for download from the
T1 website and illustrate how to disable the watchdog before the c initialization phase.
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12. API Error Codes

To communicate back to the calling application, the API returns the following status messages. These
status values will be reported by SDFlash.

Status | Definition Notes

0 STATUS_SUCCESS Operation was successful.

The API function is unable to access the flash

10 STATUS FAIL_CSM_LOCKED array due to a locked Code Security Module.

11 STATUS_FAIL_REVID_INVALID The REVID is incorrect for this API.

An invalid address (outside of the flash or
OTP bank) was passed to the API.

For the program operation, this could be
caused if the first address specified is outside
of flash/OTP or the number of words to be
programmed is such that the last address will
be outside of flash/OTP.

This error can be returned by the erase and
depletion recovery functions if an invalid

12 STATUS_FAIL_ADDR_INVALID address is used for the pre-conditioning of the
flash. In this case check that the .const
section of the APl is located in SARAM that
can be accessed by the API. This section
contains important information that is used by
the erase and depletion recovery functions.

In the case of this error, none of the values
passed to the program function will be
programmed. The flash status structure
(FLASH_ST) is not updated with any
information.

The expected PARTID did not match the
device PARTID. This would indicate that the

13 STATUS_FAIL_INCORRECT_PARTID wrong API was used. For example, using a
TMS320F2812 API on the TMS320F28235
device.
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Status

Definition

Notes

14

STATUS_FAIL_API_SILICON_MISMATCH

At the start of each API function, the content of a
boot ROM location 0x3FFFB9 is checked to
determine if the APl is ok to execute on that silicon.
In the future, Tl can change the content of this boot
ROM location if an APl becomes obsolete. This
will prevent an old API from executing on the new
silicon.

If this error code occurs, verify that that the proper
API version is being used. Check the
TMS320C2000 web site at
http://www.ti.com/c2000.

Erase Specific Status Messages

Erase had nothing to do because no valid sectors

20 STATUS_FAIL_NO_SECTOR_SPECIFIED o
were specified.
o1 STATUS. FATL_PRECONDITION Erase operation failed bgcauge the clear portion of
the pre-condition operation failed.
Erase operation failed because the sector could
22 STATUS_FAIL_ERASE not be erased with the maximum allowed number
of pulses.
23 STATUS. FATL COMPACT Erasglop_eratlon falled_becaqse the post-
conditioning (compaction) failed.
Erase operation failed because the pre-
compaction portion failed. The pre-compaction is
24 STATUS_FAIL_PRECOMPACT applied to all sectors on the device. The

FLASH_ST structure will return a fail address
corresponding to the first sector fails this step.

Program Specific Status Messages

Program operation failed because one or more

30 STATUS_FAIL_PROGRAM \
bits could not be programmed.
Program operation failed because one or more
bits were already programmed (0) that should

31 STATUS_FAIL_ZERO_BIT_ERROR have been erased (1). If this happens it could be

because the sector was not erased before
attempting to program.

Verify Specific Status Messages

40

STATUS_FAIL_VERIFY

The verify operation failed because one or more
bits did not match the reference data.
Try increasing the Flash or OTP wait states.

SDFlash

Specific Status Messages

144

Missing clock detect bit set

This is a F2823x SDFlash specific error code. It is
issued by the SDFlash interface function, not the
flash API.

This error code indicates that the MCLKSTS bit is
set within the PLLSTS register. This bit indicates
that the external clock has at some point gone
missing. When this is the case, the flash API
should not be executed as it will be at the wrong
frequency.
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